Print Page | Close Window

index issue

Printed from: Monsoon Stone Edge User Forum
Topic URL: http://www.stoneedge.net/forum/topic.asp?TOPIC_ID=2637
Printed on: 12/16/2019

Topic:


Topic author: tuttibella
Subject: index issue
Posted on: 03/09/2006 11:49:58 PM
Message:

Had to re-install Stone Edge earlier today and I checked to be sure pack/ship, inventory, and view orders were working correctly, which they were, but then had to leave for an all day meeting. After getting home tonight tried to download orders.... orders download okay, but then the fun begins. I seem to remember this same issue happening once before, but can't seem to fix it myself this time.

The issue is that upon importing there is an error that says "At DoCustomerCheck error-3800 - email is not an index in this table". All orders are then marked as paid in full, (when in fact we do not process or authorize cc's upon import), and the entire amount for all imported orders is being recorded in the first record in the order manager, (not the first record from the newly imported orders, but the first record ever). I deleted all the newly imported orders and will need to re-import them, but nothing I do seems to correct this problem. I have tried to re-link the tables (ctrl-shft-L), rebuild indexes (ctrl-shft-I), compact and repair, and the fix all. I've gotten a "error 3265 - items not found in this collection" at one point, and then when trying to rebuild the indexes get "error 3022" - which says it cannot complete the process because it would create duplicate content. I even tried uninstalling and reinstalling the program, but the issue is obviously in the data somewhere.

Any help would be appreciated.

Replies:


Reply author: kevin
Replied on: 03/10/2006 08:18:58 AM
Message:

It sounds like you may have suffered a bit of corruption in your store data file which caused an index to be dropped from the Customers table. To resolve this, perform the following:

1) Get all users out of the program
2) Backup your store data file
3) Open Order Manager and at the Main Menu press F11 to open the database window
4) Go to the "Tables" section and find the Indexes table - double click to open
5) Find the record for the Customers table, Email index and make sure that the "Unique" field is NOT checked - Close the table
6) Press CTRL+SHIFT+F to run the Order Manager's Fix Utility which will rebuild all indexes in the data file. When it is done, you will need to restart the program normally.

If you still have troubles after this point, you'll need to give tech support a call.

Kevin Smith
Stone Edge Technologies, Inc.
6198 Butler Pike
Blue Bell, PA 19422
215-641-1837 x112
kevin@stoneedge.com


Reply author: tuttibella
Replied on: 03/10/2006 09:56:16 AM
Message:

Thank you Kevin, that did the trick. I had gotten as far as the customer/email index, but couldn't remember what was supposed to be checked/unchecked.


Reply author: kivimagi
Replied on: 12/29/2009 3:35:51 PM
Message:

I have a call into support, but I'm getting this error when doing a quickbooks export.

At QBExport: Error = 3800: Primary Key is not an index in this table.

Is there a quick set of instructions for adding this index back into the table. I don't see a table called QBExport, and I only see QBExportID in the index table.

Regards,


Reply author: Barney Stone
Replied on: 12/29/2009 3:42:31 PM
Message:

Ryan -

Get everyone else out of the Order Manager. Back up your data file. Then, at the Main Menu, press control/shift/I to re-build your indexes. That might fix the problem. If not, you will have to wait for your callback from Support.


Reply author: Jared
Replied on: 12/29/2009 8:23:34 PM
Message:

You might have already talked to support, but if Barney's suggestion doesn't work and you're still waiting, I've found that compacting the local program file can sometimes resolve stupid Quickbooks exporting errors. Always backup first, of course :)


Reply author: rjjjbrown
Replied on: 12/29/2009 8:30:40 PM
Message:

Jared,

Are you dissing on QuickBooks ... lol! That's now allowed...hehehe!

Tech support fixed it for him, Access had some corruption and the index tables.

Sorry, had to give you a hard time :-)


Reply author: kivimagi
Replied on: 12/29/2009 9:50:32 PM
Message:

Just to document what happened a bit further.

Stone Edge/windows, hung up on me during an import of inventory/sku's. I had to end the task, which caused some corruption in the inventory table. At the top of this table there were a few thousand lines of ############ etc. I removed those, and things were restored. there may or may not have been some access corruption, but in the process I uninstalled access 2000, and re-installed.

Thanks to support for getting with me quickly. And to Rox for educating me in the ways of quickbooks exports.

Regards,


Monsoon Stone Edge User Forum : http://www.stoneedge.net/forum/

© Monsoon Commerce, Inc.

Close Window